Fagstoff

Funksjoner

Publisert: 11.01.2012, Oppdatert: 04.03.2017
  • Innbygg
  • Enkel visning
  • Lytt til tekst
  • Skriv ut
Krittstriper

En funksjon i et regneark er et forhåndsdefinert ord som kan skrives inn i formelen, slik at programmet gjør en beregning for oss.

Summering av celler i et regnearkSummering av celler i et regneark
Forfatter: Arne Jansen
 

Noen beregninger kan føre til at formlene i et regneark blir svært lange. Tenk deg at du har et stort regneark og skal legge sammen alle tallene som står i cellene A1–A99. I utgangspunktet skulle formelen for dette bli =A1+A2+A3+A4+A5+A6 … og så videre helt til A99.

En slik formel tar lang tid å lage, og det blir lett feil i den. Og selv om vi kanskje klarer å lage en formel med hundre plusstegn, er det jo ikke noe i veien for at regnearket kan være mye større. Tenk deg at du skal legge sammen tusen eller kanskje mange tusen celler. Da blir det temmelig opplagt at vi trenger en bedre måte å gjøre det på.

For å løse problemet med lange og kompliserte formler kan regnearket også bruke funksjoner. En funksjon er et forhåndsdefinert ord som vi skriver inn i formelen, slik at programmet utfører en større beregning for oss.

SUMMER-funksjonen

SUMMER-funksjonen brukes til å legge sammen tallrekker.

Den vanligste funksjonen er SUMMER, som brukes for å legge sammen tallrekker. I eksemplet ovenfor kunne vi brukt denne funksjonen i stedet for å skrive alle cellereferanser fra A1 til A99 med plusstegn mellom. Da ville formelen se slik ut: =SUMMER(A1:A99).

La oss se litt nærmere på formelen.

Legg først merke til at den fortsatt starter med et likhetstegn. Alle formler må starte med =, selv om de inneholder en funksjon. Glemmer du likhetstegnet, tror regnearket at du skriver en tekst.

=SUMMER betyr at regnearket skal summere en serie celler, mens (A1:A99) definerer de cellene som skal summeres.

Kolon, :, i en formel i et regneark betyr «til» og er altså ikke deletegn.

Formelen =SUMMER(A1:A99) gjør altså at regnearket summerer alle tallene det finner fra celle A1 til og med celle A99.

SUMMER-funksjonenSUMMER-funksjonen
Forfatter: Arne Jansen
 

Med en slik funksjon kan vi lage enkle formler som legger sammen så store tallrekker vi vil. Dersom vi har et kjempestort regneark og vil legge sammen mange tusen tall, kan formelen for eksempel se slik ut: =SUMMER(C3:C7800). Det vil si at vi skal summere alle tall fra celle C3 til og med celle C7800.

SUMMER-funksjonen er så mye brukt at de fleste regneark har en egen verktøyknapp for den. Knappen er vanligvis merket med det greske symbolet sigma, ∑.

Når du skal bruke SUMMER-funksjonen, plasserer du markøren i regnearket i cella nedenfor eller til høyre for de tallene du skal summere, og klikker på verktøyknappen med summeringsikonet.

Regnearket setter automatisk inn en formel med summeringsfunksjonen og de cellereferansene som skal summeres.

Oppgaver

Praktisk stoff for